2.82-SSP Mode Platform & Platformroute

Talk about anything related to Platinum Arts Sandbox here!
palm tree dreamin
Member
Member
Posts: 8
Joined: April 14th, 2015, 9:18 am
Name: Myst
Location: Right where I should be (Colorado)

2.82-SSP Mode Platform & Platformroute

Postby palm tree dreamin » April 14th, 2015, 3:18 pm

Hello!
I have a question about the platform entity in Sandbox 2.82. My understanding is that this is a working function, now, in SSP mode. I downloaded 2.82, yesterday, and only just got around the checking out the platform. There really isn't any documentation that I can see outside the editing reference and it doesn't say how to set one up. Maybe I missed something...

Well, I tried this. I added a platform to the map. No model, nothing. Leave editing mode, still nothing. Changed speed, nothing. Changed models, nothing.

I tried adding a platformroute calling it tag 0 and next 1. Then I added another, called tag 1, next 0. This brought up a nice blue line between the two, so I am thinking that's an improvement. I moved the platform to where it looked as if it would be sitting on the route, but nothing happened.

I know it must be something simple, like I missed some dialog somewhere, don't have "the right" mapmodel, it has to be placed "just so", or something has to be added to the configure, but I just can't seem to get it to show up in game. Anyone have suggestions for what I need to do?

Thanks, in advance!

:D Credendo Vides

palm tree dreamin
Member
Member
Posts: 8
Joined: April 14th, 2015, 9:18 am
Name: Myst
Location: Right where I should be (Colorado)

Re: 2.82-SSP Mode Platform & Platformroute

Postby palm tree dreamin » April 14th, 2015, 4:52 pm

Sorry, to answer my own post, but I found an answer. For anyone else looking for information:

I placed the platform, set the model, and set the yaw to 0.
I set a platformroute entity (number one) for the start of the path,
set a platformroute entity (number two) for the end,
made #1's tag = 0, next = 1.
Then, I made #2's tag = 1 and set next = 0.
Then, I saved.
Then, I left sandbox all together.
When I restarted Sandbox, TADA!, the barrel model was there and it was moving back and forth. I made some adjustments for height and it worked, just great!

Up till this point, if I just reloaded the map, there was nothing there. It may have to do with Windows xp...
Something else awesome about this in SSP mode, is your character can ride on the platform north to south, even though his path is clearly east to west. This will allow for some fun puzzle kind of stuff without having to have axis/pivot points everywhere.
Well, thanks to anyone who took the time to read this. I hope this helps someone else.

Credendo Vides


Return to “Sandbox General Chat”

Who is online

Users browsing this forum: No registered users and 1 guest