Modeling md3 and skin issues (hijacked by displaced)

Having issues not related to a specific Sandbox game mode? Get help here!
Please also read the rules for support when posting support requests.
Failure to comply with the forum rules may result in your topic being locked without resolution.
chocolatepie33
Support Team
Support Team
Posts: 2458
Joined: April 27th, 2010, 5:31 pm
IRC Username: CP

Modeling md3 and skin issues (hijacked by displaced)

Postby chocolatepie33 » September 8th, 2010, 8:54 pm

I can't seem to get my md3 to appear in sandbox. It has the blue sparkles, but no surrounding box. The model is triangulated, skinned, and I'm pretty sure I wrote the configuration file right. Any ideas on what's wrong?
Also, I can get it to appear as an .obj model, but it appears oddly, like there's no sides in some spots. Because of that, it appears very weird.
Any help?

EDIT: here's some images on the .obj problem: 126 125 124 123
The third one looks like it's looking @ the sky, but I'm underneath the portal, looking up at the arch.
Last edited by chocolatepie33 on September 12th, 2010, 4:03 pm, edited 1 time in total.
Julius wrote:Contribute to http://www.opengameart.org NOW!

Save the wiki!

User avatar
daniel_san
Moderator
Moderator
Posts: 84
Joined: September 8th, 2009, 11:03 pm
Name: Dan
IRC Username: daniel_san
Contact:

Re: md3/obj issues

Postby daniel_san » September 8th, 2010, 11:42 pm

Go into edit mode, select all faces and press ctrl + n.
This will recalculate all face normals to point outwards.

Some random info on normals:
http://docs.autodesk.com/ACD/2010/ENU/AutoCAD%202010%20User%20Documentation/index.html?url=WS1a9193826455f5ffa23ce210c4a30acaf-7c96.htm,topicNumber=d0e184501
First and second part (after the first picture) being most relevant to your problem here.

Also you may want to select your model in object mode, and set shading to smooth before exporting.
http://wiki.blender.org/index.php/Doc:Manual/Modeling/Meshes/Smoothing
Good luck and take care.

-daniel_san

chocolatepie33
Support Team
Support Team
Posts: 2458
Joined: April 27th, 2010, 5:31 pm
IRC Username: CP

Re: md3/obj issues

Postby chocolatepie33 » September 10th, 2010, 5:58 pm

alright, thanks dan, I'll try it.
Julius wrote:Contribute to http://www.opengameart.org NOW!

Save the wiki!

chocolatepie33
Support Team
Support Team
Posts: 2458
Joined: April 27th, 2010, 5:31 pm
IRC Username: CP

Re: md3/obj issues

Postby chocolatepie33 » September 10th, 2010, 7:27 pm

I tried it md3, same as before, and as an obj... it didn't show. Just like the md3. Maybe it's the smooth I did wrong...

EDIT: I removed smooth, and it showed up, and it looked good... I just want to noclip it.
Julius wrote:Contribute to http://www.opengameart.org NOW!

Save the wiki!

displaced
Member
Member
Posts: 8
Joined: August 22nd, 2010, 11:37 pm
Name: displaced
IRC Username: displaced

Re: md3/obj issues

Postby displaced » September 10th, 2010, 9:01 pm

ok, I'm having this same issue. I'm using debian testing and the latest version of sandbox installed from the repositories and it puts things in the standard debian places. most of the stuff is in /usr/share/sandboxgamemaker/packages then in the users /home/ folder I have a .platinumarts/packages/base/ folder. anything that I create is to be stored in the ./platinumarts/packages/base/ folder. This is where the program saves maps i've created. I was told that if I wanted to add objects that I create to the maps I should put them in this folder also. This does not work, at all. but if I put them in the /usr/share/sandboxgamemaker/packages/ folder, they work. I'm still having issues with texture mapping but at least i get the object to show after adding it with the mmodels command. The main issue I have with this is that it requires root access to put ANYTHING in that folder. how are you to do this if you don't have root access? secondly, I'm also using this program at my school to teach game logic and design. This program has forced me to explain game engine limitations and work arounds.
Now I have 3-6 very good blender modelers who can create just about anything i would like to ask for and explaining the low poly models required for this game engine was kinda strange especially since they are mostly teenage kids who have never dealt with 3d modeling before. We are in an ldap and network file system setup. This means that the /home directory is not stored on the local machine, it's stored on our main server. So... to make a long story short.
1: storing the files in the /usr/share/sandboxgamemaker/packages/ is impossible because they will never have root access to any of the machines and getting the system to recognize anything other than a map in /platinumarts/packages/base/ doesn't work
2: how do you get textures to map correctly because even with it uv mapped to the mesh in blender. in the game, the maps don't seem to map correctly.

User avatar
daniel_san
Moderator
Moderator
Posts: 84
Joined: September 8th, 2009, 11:03 pm
Name: Dan
IRC Username: daniel_san
Contact:

Re: md3/obj issues

Postby daniel_san » September 10th, 2010, 9:47 pm

@ chocolatepie
if you want the model to have no clipping, just do that through the md3.cfg
http://sauerbraten.org/docs/models.html#mdlcollide
mdlcollide is the command youd use in your cfg to control that.

@displaced
My first suggestion would be to not use versions of sandbox in linux repositories. Use the multiplatform .zip from the main site in a local directory.(i understand this might be hard for the school setting your in)
Dont get me wrong its awesome people took the time to include them in there, but if youre actually trying to create art assets ect. its a pain due to permissions like you said.
Much easier to work out of a local directory, a flash drive might even work.
As for your model/texture/uv mapping issues.
Make sure your md3skin line matches whatever name your object is named in blender.
for eg:
md3skin Cube skin.jpg
Cube would be the name of your object in blender.
Hope this helped.
Take care.

-daniel_san

displaced
Member
Member
Posts: 8
Joined: August 22nd, 2010, 11:37 pm
Name: displaced
IRC Username: displaced

Re: md3/obj issues

Postby displaced » September 10th, 2010, 10:33 pm

ok, we tried that. The fact of the matter is that I'm the network admin and i can put them in that folder if I need to. that causes the files to become a local file only, so you can't share the map. secondly, we tried the multiplatform setup and it doesn't work. can't get the program to run that way at all. thirdly why would this not work at all? as to the textures, they are mapped correctly and the file is named after the blend file and the mesh itself, so I end up with something like name_object.jpg
again, it maps correctly in blender, not in the game engine. we are using this program to share our maps.

Hirato
Developer
Developer
Posts: 689
Joined: May 30th, 2009, 1:23 pm
IRC Username: hirato

Re: md3/obj issues

Postby Hirato » September 10th, 2010, 10:35 pm

whatever is in ~/.platinumarts WILL override whatever is in /usr/games/sandboxgamemaker or wherever it's installed.
(that's ~/ DOT - platinumarts )

as an example, let's pretend that you have two maps, both with identical names, ie ~/.platinumarts/packages/base/bob.ogz and /use/games/sandboxgamemaker/packages/base/bob.ogz
if you were to start sandbox and type /map bob, ~/.platinumarts/packages/base/bob.ogz would be loaded instead of the copy in /usr/games

as another example: if you wanted to add more models, there are two ways of doing it, but both involve placing it in ~/.platinumarts/packages/models
You can either load these models in the map cfg itself, OR you can copy /usr/games/sandboxgamemaker/data/default_map_models.cfg to ~/.platinumarts/data/default_map_models.cfg and add your new models onto the end.

========

in regards to the model problems, here's a list of things to check
  • You're not using MD2
  • You're only using one texture per mesh
  • You're loading the correct skin for the correct mesh
  • You've entered the name of the mesh correctly (CASE SENSITIVE)

also in regards to skins there are a few more things to note with it
firstly, if you type md3skin * skin.jpg, skin.jpg will be used to texture ALL meshes inside the file.
secondly, if you don't bother to add a md3skin line (or one for the appropriate model format), the engine will automatically try to use skin.jpg or skin.png for all meshes
This is not a url, clicking it is pointless

displaced
Member
Member
Posts: 8
Joined: August 22nd, 2010, 11:37 pm
Name: displaced
IRC Username: displaced

Re: md3/obj issues

Postby displaced » September 11th, 2010, 12:06 am

I'm not using md2, I'm using md3. 1 texture per mesh. one mesh per export. the mesh is textured with the correct texture, it's not mapped correctly. it's like the texture is too large.instead of it mapping correctly I'm getting a small part of the texture in the wrong place. I did add an md3skin line and it points to the correct jpg. I uv mapped it and it is done correctly in blender.

displaced
Member
Member
Posts: 8
Joined: August 22nd, 2010, 11:37 pm
Name: displaced
IRC Username: displaced

Re: md3/obj issues

Postby displaced » September 11th, 2010, 3:17 am

You are right, it is /.platinumarts/packages/base I knew that and miss typed it.
I also just tried adding the models folder to that folder and putting my model in it. it still doesn't work with the /mmodel filename command. It does add the name to the map models list. when you add it, you get a sparkle point and nothing else. Just out of curiosity I decided to try adding something that didn't exist in that same manner, it added the name with no error. and you could add this object and get exactly the same results, a sparkle point and nothing else, again with no error.


Return to “Sandbox General Support”

Who is online

Users browsing this forum: No registered users and 1 guest