Modeling md3 and skin issues (hijacked by displaced)

Having issues not related to a specific Sandbox game mode? Get help here!
Please also read the rules for support when posting support requests.
Failure to comply with the forum rules may result in your topic being locked without resolution.
User avatar
daniel_san
Moderator
Moderator
Posts: 84
Joined: September 8th, 2009, 11:03 pm
Name: Dan
IRC Username: daniel_san
Contact:

Re: md3/obj issues

Postby daniel_san » September 11th, 2010, 10:58 am

As far as your model problem goes, it might be a random setting in blender you're missing.
If you wouldn't mind, zip up your .blend, md3, md3cfg, texture, and upload to rapidshare or somewhere.
I'll take a look and see if I can figure out what's wrong. Chances are if it'll work for me, it should for you.

-daniel_san

chocolatepie33
Support Team
Support Team
Posts: 2458
Joined: April 27th, 2010, 5:31 pm
IRC Username: CP

Re: md3/obj issues

Postby chocolatepie33 » September 11th, 2010, 4:16 pm

This got way hijacked! Oh well. My problem got answered.
Julius wrote:Contribute to http://www.opengameart.org NOW!

Save the wiki!

displaced
Member
Member
Posts: 8
Joined: August 22nd, 2010, 11:37 pm
Name: displaced
IRC Username: displaced

Re: md3/obj issues

Postby displaced » September 11th, 2010, 5:45 pm

yes it did and I’m sorry, thanks though

displaced
Member
Member
Posts: 8
Joined: August 22nd, 2010, 11:37 pm
Name: displaced
IRC Username: displaced

Re: md3/obj issues

Postby displaced » September 11th, 2010, 8:51 pm

all files zipped and uploaded to rapidshare
http://rapidshare.com/files/418529683/mayan_corner.zip
this is a very simple object created to learn mapping techniques in sandbox, I had tried once before and gotten pretty much the same error. I couldn't put it in the .platinumarts folder but it sorta works in the ./usr/share/sandboxgamemaker/packages/models folder. putting it there allows me to instantly test whether it works with the /mmodel command. the textures do not map correctly but if you know how to look at uv mapping in blender, you will see that the textures do map correctly.

User avatar
daniel_san
Moderator
Moderator
Posts: 84
Joined: September 8th, 2009, 11:03 pm
Name: Dan
IRC Username: daniel_san
Contact:

Re: md3/obj issues

Postby daniel_san » September 11th, 2010, 9:54 pm

Okay like I said before make sure your md3skin line is correct, which it is not.
What you had in your md3.cfg:

md3load mayan_corner.md3
md3skin corner_mayan_corner(2).jpg
mdlscale 2000

You never told md3skin which mesh to map corner_mayan_corner(2).jpg to.
In blender your objects name is mayan_corner.

Screenshot.png


Therefore your md3.cfg should be:

md3load mayan_corner.md3
md3skin mayan_corner corner_mayan_corner(2).jpg
mdlscale 2000

work.png


I think you over confused yourself with your naming conventions.
If you look through other models included in sandbox you'll notice they have a consistent naming convention.
tris.md3 for your md3mesh, and skin.xyz for your textures.
For eg. this is much easier to read and understand than what you had. (renaming your object in blender to just corner)

md3load tris.md3
md3skin corner skin.jpg
mdlscale 2000

Hope this clarifies your issues. All should work for you now.
Good luck and take care.

-daniel_san

displaced
Member
Member
Posts: 8
Joined: August 22nd, 2010, 11:37 pm
Name: displaced
IRC Username: displaced

Re: md3/obj issues

Postby displaced » September 11th, 2010, 10:56 pm

so you are saying that you name the object and the jpg that goes on it in your md3skin declaration?
does this solve the problem of where the file is stored?
so the /mmodel command doesn't have anything to do with the .md3 file, it's the name of the folder that it's in.
Last edited by displaced on September 11th, 2010, 11:03 pm, edited 1 time in total.

User avatar
daniel_san
Moderator
Moderator
Posts: 84
Joined: September 8th, 2009, 11:03 pm
Name: Dan
IRC Username: daniel_san
Contact:

Re: md3/obj issues

Postby daniel_san » September 11th, 2010, 11:01 pm

Yes thats exactly what im saying, just make sure your objects name in blender is in your md3skin line.
And yes this should solve your problem regardless of where the files are being stored(/usr/share/wherever)
Sorry for the confusion. Try it out it should work for you now.
Using this below in your cfg should work for the md3 you posted like in my second screenshot.

md3load mayan_corner.md3
md3skin mayan_corner corner_mayan_corner(2).jpg
mdlscale 2000

like i said though, all the mayan_corner nonsense names lead to confusion, so you should simplify.
take care.

-daniel_san

displaced
Member
Member
Posts: 8
Joined: August 22nd, 2010, 11:37 pm
Name: displaced
IRC Username: displaced

Re: md3/obj issues

Postby displaced » September 11th, 2010, 11:14 pm

that makes perfect sense if i'm modeling just for this game engine. since I am not, i name every object i create and name the blend file appropriately. this way if i need to link an object from one blend file to another i don't have to guess which "box" I'm using. otherwise thank you. let's see if this works

It works and also solves the issue with the files having to be in the read only directory. thank you again.

chocolatepie33
Support Team
Support Team
Posts: 2458
Joined: April 27th, 2010, 5:31 pm
IRC Username: CP

Re: md3/obj issues

Postby chocolatepie33 » September 12th, 2010, 4:02 pm

Alright, I'm changing the topic name, hold on...
Julius wrote:Contribute to http://www.opengameart.org NOW!

Save the wiki!

User avatar
klimyriad
Support Team
Support Team
Posts: 969
Joined: December 23rd, 2009, 1:43 pm
Name: liam
Contact:

Re: Modeling md3 and skin issues (hijacked by displaced)

Postby klimyriad » September 12th, 2010, 4:13 pm

Lol that is funny nice one runescapedj anyway i not good in modelling and that so i could not answer but this has help me allot too.
Firstspace the attack Progress. Image
Maps= Image finishing the town of hisal map.
Models and textures Image Just started finding these.
Menus, script's and other stuff. Image


Return to “Sandbox General Support”

Who is online

Users browsing this forum: No registered users and 2 guests