Page 1 of 1

2.7.1 - ATI/AMD related issues and workarounds

Posted: January 15th, 2012, 2:15 am
by Hirato
I don't know how many years it has been, but ATI/AMD has terrible OpenGL drivers, a number of issues seem to have surfaced recently.
Resurfaced would perhaps be the better word, They finally decided to change the vendor string from ATI Technologies to Advaned Micro Devices which broke our detection heuristics.
If you're using the official ATI/AMD drivers on Windows or the fglrx driver on Linux, read on, otherwise this doesn't concern you.

Crashes
In short, ATI/AMD cannot draw lines.
They can, but doing so makes them leak memory... a LOT of memory.
Eventually this results in sandbox using 2/4GB of it, and crashing due to being unable to allocate anymore.

This is due to a bug in their driver that is OVER 2 YEARS OLD.
If you're an ATI/AMD customer, please, PLEASE, get them to fix it!

Terrain flickering
This is also due to a bug in their driver and also has its own workaround.
I'm not sure how to describe it, but I've received a few reports that parts of the world literally become "invisible" in editmode.

Temporary Solution
You will need to activate the workarounds manually.
The easiest way to do this, would be to add the following lines into your autoexec.cfg.
Future releases will provide slightly better heuristics...

Code: Select all

ati_line_bug 1
ati_dph_bug 1


If you have some other issues, such as non-memory related crashes or model, texture or skybox corruption, have a play with the other ati_* variables.

Re: 2.7.1 - ATI/AMD related issues and workarounds

Posted: January 16th, 2012, 6:27 am
by Tony
Hirato wrote: have a play with the other ati_* variables.


Interesting.
..."other" ati_ * variables.