Just installed 2.8

Having issues not related to a specific Sandbox game mode? Get help here!
Please also read the when posting support requests.

User avatar
johnno56
Member
Member
Posts: 158
Joined: June 12th, 2009, 4:06 am
Name: John
Location: Melbourne, Australia
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Just installed 2.8

Postby johnno56 » August 21st, 2012, 6:53 pm

Hi guys,

Just installed SB 2.8 on mu Ubuntu 12.04 box and it will not start.

Installed via root user and installed globally just fine (using the default directories) without any posted errors. Woo Hoo!

Selected 'SSP' via the Games menu and nothing. Games menu disappears (as it should) and left staring at my desktop. No message boxes, no error messages, just my normal desktop. Ran "System Monitor" and re-ran. Nothing showed up in the manager. As though it didn't execute. Checked all the "sandbox_client_32*" binaries and they are all owned by "root" and none of them had permission to be executed by any user (including root). Root user could only read and write, all other users could read only. Modified sandbox_client_32_ssp to be executed by all users. Re-ran. Same result. My brain hurts.

Am I doing something wrong or should I go back to SB 2.7?

Regards

J
May your journey be free of incident.

Live long and prosper.

ticker
Member
Member
Posts: 21
Joined: July 22nd, 2010, 9:27 pm
Name: Tom
IRC Username: none
Contact:

Re: Just installed 2.8

Postby ticker » August 22nd, 2012, 1:09 am

I tried out the Multiplatform build on an iMac running OSX 10.7.4 - using the Sandbox Launcher from Nov. 2010 (10.2 Mb) that works OK for both 2.6.1 and 2.7 versions on the same Mac. First, it froze my machine then on re-boot put up weird text dialogs as if the keyboard was re-mapped. Had I been able to interpret the "text" I may have been able to put up a standard map, but I was just happy to be able to exit back to the desktop.

Any clues anyone?? - ticker

Hirato
Developer
Developer
Posts: 689
Joined: May 30th, 2009, 1:23 pm
IRC Username: hirato
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Just installed 2.8

Postby Hirato » August 22nd, 2012, 10:12 am

@johnno56 It sounds like you're using custom hand-crafted shortcuts, or at least some method we don't support directly.
In any case, I'm more curious about console output when you run them directly.
You should meet all the requirements, I mean, ubuntu 12.04 does ship with a kernel as new, or newer than 2.6.32, right?

There is a bundled "install.sh" script I wrote quickly that should set things up more or less correctly - it worked for me!


@ticker Windows is sort of the second class citizen - you've got tons of inconvenient BAT files, a stdout.txt (no console output), and development is rather cumbersome due to that and other factors...
But OS X, by comparison is the red-headed stepchild, and as such you're unfortunately by your lonesome.
But yeah, if you're using 2010 builds with PAS 2.8.0, released just days back, expect problems....

In any event, I would advise you to install a Linux distribution ( www.debian.org ) either along side OS X or inside a VM for running sandbox. I doubt anyone here can help you with mac troubles.
This is not a url, clicking it is pointless

User avatar
johnno56
Member
Member
Posts: 158
Joined: June 12th, 2009, 4:06 am
Name: John
Location: Melbourne, Australia
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Just installed 2.8

Postby johnno56 » August 22nd, 2012, 3:09 pm

Hirato,

Thank you for replying so quickly. I seem to have this problem when a new version is released.. or maybe I am just jinxed?

Ubuntu 12.04, at the moment, is running with the 3.0.2-27 kernel. I forgot to mention in my previous post that I installed SB 2.8 via the "install.sh" script. As I also stated, SB installed fine without errors. I used the "default" directory locations. I ran the script "as is".

I have a sneaking suspicion that it might be an OS problem. For the first time, since Ubuntu 6.04, I have not had any error messages pop up on the screen. With recent updates, those messages have cleared up. I do not have as much trust in Ubuntu as I once did. I am concidering changing.

Just as an aside. I had removed SB 2.7 some time ago and decided to re-install, in light of the current problem, and bingo! It installed and ran just fine "out of the box". The only difference was that I used the SB 2.7.1 that was included in the Ubuntu repository. Took ages to install, but install it did.

I am going to try SB 2.8 on another "flavour" of Linux. Just to hopefully eliminate a OS version problem.

As I have only just reinstalled 2.7.1, I can try reinstalling 2.8, and perhaps give you more information. But I do not know what information and where to find it. I am assuming a log of some sort. What do you think?

Regards

J

ps: Attached is the console output after a fresh download and install on Linux Mint (Mint - nothing else installed - as is). And just for curiosity, I removed 2.8 and installed 2.7.1, via the install script. The exact same problem. Even running as Root user, permission was denied. My brain hurts again....

I am almost of the opinion that it may be also a dependency issue. The Ubuntu reposiory version (2.7.1) installs and runs fine. Whereas the script install does not. Just a thought...
Attachments
Screenshot-Terminal-1.png
May your journey be free of incident.

Live long and prosper.

Hirato
Developer
Developer
Posts: 689
Joined: May 30th, 2009, 1:23 pm
IRC Username: hirato
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Just installed 2.8

Postby Hirato » August 22nd, 2012, 8:14 pm

This is not a url, clicking it is pointless

User avatar
johnno56
Member
Member
Posts: 158
Joined: June 12th, 2009, 4:06 am
Name: John
Location: Melbourne, Australia
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Just installed 2.8

Postby johnno56 » August 28th, 2012, 6:25 pm

It is not my intention to be a pest about this problem, but it still exists.

I used the new install script and it ran fine, including setting permisions, util completion with no errors.

I made sure that the 'sandbox_unix' binary was able to be executed.

After the installation was done and presented with my terminal prompt, I entered the recommended command 'sandbox'. I was then presented with a "you do not have permission...". No problem. Used 'sudo sandbox' (plus password). Same result. "you do not have permission". Getting a bit annoyed at this point. Finally went through the "Games" menu and executed 'Sandbox FPS'. Nothing. No game. No error message. Staring at my regular desktop. I am wondering how far I can throw my keyboard at this stage....

The problem has to be either me or my machines (laptop and PC) as I do not see anyone else having this problem. I have very little hair and am about to remove it.

I have removed SB 2.8 and am currently looking for my SB 2.7.1

Perhaps I will try at a later date when I am no so upset. This rant is not aimed at you. If you perceived it that way, then I appologize. I am annoyed at myself for not being able to solve a simple install problem.

I want to thank you for all the help you have provided and appreciate your efforts. I feel that they have been wasted on this noob.

Regards

J
May your journey be free of incident.

Live long and prosper.

Hirato
Developer
Developer
Posts: 689
Joined: May 30th, 2009, 1:23 pm
IRC Username: hirato
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Just installed 2.8

Postby Hirato » August 29th, 2012, 9:59 am

get me an 'ls -la' of /usr/local/share/games/sandbox and /usr/local/share/games/sandbox/bin
Absolutely everything should be in order after those changes to the script...
This is not a url, clicking it is pointless

User avatar
johnno56
Member
Member
Posts: 158
Joined: June 12th, 2009, 4:06 am
Name: John
Location: Melbourne, Australia
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Just installed 2.8

Postby johnno56 » September 2nd, 2012, 1:40 am

May your journey be free of incident.

Live long and prosper.

Hirato
Developer
Developer
Posts: 689
Joined: May 30th, 2009, 1:23 pm
IRC Username: hirato
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Just installed 2.8

Postby Hirato » September 2nd, 2012, 6:03 am

that seems to be the crux of the problem, you lack permissions to enter the directories in there.
the directories all need the 'x' flag set to true, unfortunately I don't have any quick one-liners that won't set everything to executable as a consequence.

you can try 'chmod -R +X /usr/local/share/games/sandbox/' though.

But eh, if it's this big a problem, just keep it in your home and run it from there.
This is not a url, clicking it is pointless

User avatar
johnno56
Member
Member
Posts: 158
Joined: June 12th, 2009, 4:06 am
Name: John
Location: Melbourne, Australia
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Just installed 2.8

Postby johnno56 » September 2nd, 2012, 7:10 pm

Thank you for your suggestions and patience. Much appreciated.

J
May your journey be free of incident.

Live long and prosper.


[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Return to “Sandbox General Support”

Who is online

Users browsing this forum: Bing [Bot] and 7 guests