Page 1 of 2

Just installed 2.8

Posted: August 21st, 2012, 6:53 pm
by johnno56
Hi guys,

Just installed SB 2.8 on mu Ubuntu 12.04 box and it will not start.

Installed via root user and installed globally just fine (using the default directories) without any posted errors. Woo Hoo!

Selected 'SSP' via the Games menu and nothing. Games menu disappears (as it should) and left staring at my desktop. No message boxes, no error messages, just my normal desktop. Ran "System Monitor" and re-ran. Nothing showed up in the manager. As though it didn't execute. Checked all the "sandbox_client_32*" binaries and they are all owned by "root" and none of them had permission to be executed by any user (including root). Root user could only read and write, all other users could read only. Modified sandbox_client_32_ssp to be executed by all users. Re-ran. Same result. My brain hurts.

Am I doing something wrong or should I go back to SB 2.7?



Re: Just installed 2.8

Posted: August 22nd, 2012, 1:09 am
by ticker
I tried out the Multiplatform build on an iMac running OSX 10.7.4 - using the Sandbox Launcher from Nov. 2010 (10.2 Mb) that works OK for both 2.6.1 and 2.7 versions on the same Mac. First, it froze my machine then on re-boot put up weird text dialogs as if the keyboard was re-mapped. Had I been able to interpret the "text" I may have been able to put up a standard map, but I was just happy to be able to exit back to the desktop.

Any clues anyone?? - ticker

Re: Just installed 2.8

Posted: August 22nd, 2012, 10:12 am
by Hirato
@johnno56 It sounds like you're using custom hand-crafted shortcuts, or at least some method we don't support directly.
In any case, I'm more curious about console output when you run them directly.
You should meet all the requirements, I mean, ubuntu 12.04 does ship with a kernel as new, or newer than 2.6.32, right?

There is a bundled "" script I wrote quickly that should set things up more or less correctly - it worked for me!

@ticker Windows is sort of the second class citizen - you've got tons of inconvenient BAT files, a stdout.txt (no console output), and development is rather cumbersome due to that and other factors...
But OS X, by comparison is the red-headed stepchild, and as such you're unfortunately by your lonesome.
But yeah, if you're using 2010 builds with PAS 2.8.0, released just days back, expect problems....

In any event, I would advise you to install a Linux distribution ( ) either along side OS X or inside a VM for running sandbox. I doubt anyone here can help you with mac troubles.

Re: Just installed 2.8

Posted: August 22nd, 2012, 3:09 pm
by johnno56

Thank you for replying so quickly. I seem to have this problem when a new version is released.. or maybe I am just jinxed?

Ubuntu 12.04, at the moment, is running with the 3.0.2-27 kernel. I forgot to mention in my previous post that I installed SB 2.8 via the "" script. As I also stated, SB installed fine without errors. I used the "default" directory locations. I ran the script "as is".

I have a sneaking suspicion that it might be an OS problem. For the first time, since Ubuntu 6.04, I have not had any error messages pop up on the screen. With recent updates, those messages have cleared up. I do not have as much trust in Ubuntu as I once did. I am concidering changing.

Just as an aside. I had removed SB 2.7 some time ago and decided to re-install, in light of the current problem, and bingo! It installed and ran just fine "out of the box". The only difference was that I used the SB 2.7.1 that was included in the Ubuntu repository. Took ages to install, but install it did.

I am going to try SB 2.8 on another "flavour" of Linux. Just to hopefully eliminate a OS version problem.

As I have only just reinstalled 2.7.1, I can try reinstalling 2.8, and perhaps give you more information. But I do not know what information and where to find it. I am assuming a log of some sort. What do you think?



ps: Attached is the console output after a fresh download and install on Linux Mint (Mint - nothing else installed - as is). And just for curiosity, I removed 2.8 and installed 2.7.1, via the install script. The exact same problem. Even running as Root user, permission was denied. My brain hurts again....

I am almost of the opinion that it may be also a dependency issue. The Ubuntu reposiory version (2.7.1) installs and runs fine. Whereas the script install does not. Just a thought...

Re: Just installed 2.8

Posted: August 22nd, 2012, 8:14 pm
by Hirato
the sandbox_unix script needs +x, as well as the binaries.

I've just revised the copy in SVN to set permissions as well, try this as your

Code: Select all

# dear packagers, please run this script as follows in a chroot jail
# PREFIX=/path/to/install ./

if [ "${PREFIX}" == "" ]
	echo "You are installing sandbox globally, if you wish to abort, hit Ctrl-C now"
	echo ""
	echo "Enter installation path..."
	echo "default: /usr/local/share/games"
	read PREFIX

	if [ "${PREFIX}" == "" ]

	echo "Sandbox will be installed in \"${PREFIX}/sandbox\""
	echo "Press enter to continue"
	read CC

if [ -e "${PREFIX}/sandbox" ]
	echo "NOTE, \"${PREFIX}/sandbox\" already exists - removing"
	rm -rf "${PREFIX}/sandbox"

echo "Creating directory \"${PREFIX}/sandbox\""
mkdir -p "${PREFIX}/sandbox"
if [ $? -ne 0 ]
	echo "Failed to create directory, do you have permission?"
	exit 1

echo "Copying files to \"${PREFIX}/sandbox\" (this may take a while)"
cp -r . "${PREFIX}/sandbox"
if [ $? -ne 0 ]
	echo "Failed to copy files, do you have permission?"
	exit 1

echo "Creating symlink from \"/usr/bin/sandbox\" to \"${PREFIX}/sandbox/sandbox_unix\""
if [ -e "/usr/bin/sandbox" ]
	echo "NOTE, \"/usr/bin/sandbox\" exists - removing"
	rm -f "/usr/bin/sandbox"

ln -s "${PREFIX}/sandbox/sandbox_unix" "/usr/bin/sandbox"
if [ $? -ne 0 ]
	echo "Failed to create symlink, do you have permission?"
	exit 1

echo "Setting file permissions to 0664 and owner to root..."
chown -R root "${PREFIX}/sandbox"
chgrp -R root "${PREFIX}/sandbox"
chmod -R o-w "${PREFIX}/sandbox"

echo "Setting executable bits on scripts and binaries (just in case)"
chmod +x "${PREFIX}/sandbox/sandbox_unix"
chmod +x "${PREFIX}/sandbox/sandbox_{client,server}_{32,64}_*"

echo "Installing pixmaps to /usr/share/pixmaps"
cp ./linux/*.png "/usr/share/pixmaps"

echo "Installing .desktop files to /usr/share/applications"
cp ./linux/*.desktop "/usr/share/applications"

echo "Sandbox has been successfully installed"
echo ""
echo "To fully uninstall sandbox, run the following commands"
echo "rm /usr/bin/sandbox"
echo "rm -r \"${PREFIX}/sandbox\""
echo "rm /usr/share/pixmaps/sandbox_*"
echo "rm /usr/share/applications/sandbox_*"
echo ""
echo "To run sandbox, simply enter \"sandbox\" into your shell of choice"
echo "or select one of the launcher from your desktop's menu under the \"Games\" subtree"

Re: Just installed 2.8

Posted: August 28th, 2012, 6:25 pm
by johnno56
It is not my intention to be a pest about this problem, but it still exists.

I used the new install script and it ran fine, including setting permisions, util completion with no errors.

I made sure that the 'sandbox_unix' binary was able to be executed.

After the installation was done and presented with my terminal prompt, I entered the recommended command 'sandbox'. I was then presented with a "you do not have permission...". No problem. Used 'sudo sandbox' (plus password). Same result. "you do not have permission". Getting a bit annoyed at this point. Finally went through the "Games" menu and executed 'Sandbox FPS'. Nothing. No game. No error message. Staring at my regular desktop. I am wondering how far I can throw my keyboard at this stage....

The problem has to be either me or my machines (laptop and PC) as I do not see anyone else having this problem. I have very little hair and am about to remove it.

I have removed SB 2.8 and am currently looking for my SB 2.7.1

Perhaps I will try at a later date when I am no so upset. This rant is not aimed at you. If you perceived it that way, then I appologize. I am annoyed at myself for not being able to solve a simple install problem.

I want to thank you for all the help you have provided and appreciate your efforts. I feel that they have been wasted on this noob.



Re: Just installed 2.8

Posted: August 29th, 2012, 9:59 am
by Hirato
get me an 'ls -la' of /usr/local/share/games/sandbox and /usr/local/share/games/sandbox/bin
Absolutely everything should be in order after those changes to the script...

Re: Just installed 2.8

Posted: September 2nd, 2012, 1:40 am
by johnno56
Hirato wrote:get me an 'ls -la' of /usr/local/share/games/sandbox and /usr/local/share/games/sandbox/bin
Absolutely everything should be in order after those changes to the script...
I re-installed SB 2.8 as per the "new" install script and created a text file for each "ls -la" and have attached them. One thing I noticed when performing the two commands, was that, when the second command was performed it need the superuser to do it. (ie: for the "bin" directory - sounds a bit odd?)

/usr/local/share/games/sandbox is "dir01.txt"
/usr/local/share/games/sandbox/bin is dir02.txt

"txt extentions not permitted... submitted text list instead... sorry."

  • total 4608
    drwxr-sr-x 9 root root 4096 Sep 2 16:22 .
    drwxrwsr-x 4 root staff 4096 Sep 2 16:22 ..
    drwx--S--- 2 root root 4096 Sep 2 16:22 bin
    -rw-r--r-- 1 root root 76 Sep 2 16:22 CLICK_ME_TO_START.bat
    drwx--S--- 10 root root 4096 Sep 2 16:22 data
    -rw-r--r-- 1 root root 219 Sep 2 16:22 DISCLAIMER.txt
    drwx--S--- 2 root root 4096 Sep 2 16:22 docs
    -rw-r--r-- 1 root root 1186 Sep 2 16:22 _EDUCATORS_README.txt
    -rw-r--r-- 1 root root 212 Sep 2 16:22 Facebook Page.url
    -rw-r--r-- 1 root root 154 Sep 2 16:22 Free Game News and Free Games To Play.url
    -rwxr-xr-x 1 root root 2638 Sep 2 16:22
    -rw-r--r-- 1 root root 1931 Sep 2 16:22
    -rw-r--r-- 1 root root 139376 Sep 2 16:22 launcher
    -rw-r--r-- 1 root root 89324 Sep 2 16:22 launcher_new
    -rw-r--r-- 1 root root 2487 Sep 2 16:22 LICENSE.txt
    drwx--S--- 2 root root 4096 Sep 2 16:22 linux
    -rw-r--r-- 1 root root 87 Sep 2 16:22 MovieCube.bat
    drwx--S--- 3 root root 4096 Sep 2 16:22 my_stuff
    drwx--S--- 31 root root 4096 Sep 2 16:22 packages
    -rw-r--r-- 1 root root 89 Sep 2 16:22 Platinum Arts Sandbox Forum - Ask Questions Here!.url
    -rw-r--r-- 1 root root 87 Sep 2 16:22 Platinum Arts Sandbox Help Section.url
    -rw-r--r-- 1 root root 98 Sep 2 16:22 Platinum Arts Sandbox Newsletter Signup.url
    -rw-r--r-- 1 root root 83 Sep 2 16:22 Platinum Arts Sandbox Website.url
    -rw-r--r-- 1 root root 91 Sep 2 16:22 RoseStorm.bat
    -rw-r--r-- 1 root root 69 Sep 2 16:22 RPG.bat
    -rw-r--r-- 1 root root 171325 Sep 2 16:22 _SandBoxLauncher
    -rw-r--r-- 1 root root 4144455 Sep 2 16:22 _SandBoxLauncher.exe
    -rwxr-xr-x 1 root root 5047 Sep 2 16:22 sandbox_unix
    -rw-r--r-- 1 root root 56 Sep 2 16:22 server.bat
    -rw-r--r-- 1 root root 1833 Sep 2 16:22 server-init.cfg
    -rw-r--r-- 1 root root 69 Sep 2 16:22 SideScroller.bat
    drwx--S--- 19 root root 4096 Sep 2 16:22 src
    -rw-r--r-- 1 root root 35523 Sep 2 16:22 uninstall.exe
    -rw-r--r-- 1 root root 143 Sep 2 16:22 VehicleSimulator.bat
    -rw-r--r-- 1 root root 78 Sep 2 16:22 WaterGunWars.bat
    -rw-r--r-- 1 root root 151 Sep 2 16:22 Water Gun Wars Webpage.url
  • total 44256
    drwx--S--- 2 root root 4096 Sep 2 16:22 .
    drwxr-sr-x 9 root root 4096 Sep 2 16:22 ..
    -rw-r--r-- 1 root root 328192 Sep 2 16:22 libFLAC-8.dll
    -rw-r--r-- 1 root root 204288 Sep 2 16:22 libjpeg-8.dll
    -rw-r--r-- 1 root root 24064 Sep 2 16:22 libogg-0.dll
    -rw-r--r-- 1 root root 151552 Sep 2 16:22 libpng15-15.dll
    -rw-r--r-- 1 root root 408064 Sep 2 16:22 libtiff-5.dll
    -rw-r--r-- 1 root root 163840 Sep 2 16:22 libvorbis-0.dll
    -rw-r--r-- 1 root root 36352 Sep 2 16:22 libvorbisfile-3.dll
    -rw-r--r-- 1 root root 180224 Sep 2 16:22 libwebp-2.dll
    -rw-r--r-- 1 root root 438 Sep 2 16:22 readme_SDL.txt
    -rwxr-xr-x 1 root root 2508848 Sep 2 16:22 sandbox_client_32_fps
    -rwxr-xr-x 1 root root 2127828 Sep 2 16:22 sandbox_client_32_krs
    -rwxr-xr-x 1 root root 2298604 Sep 2 16:22 sandbox_client_32_movie
    -rwxr-xr-x 1 root root 2683392 Sep 2 16:22 sandbox_client_32_rpg
    -rwxr-xr-x 1 root root 2140184 Sep 2 16:22 sandbox_client_32_ssp
    -rw-r--r-- 1 root root 2578616 Sep 2 16:22 sandbox_client_64_fps
    -rw-r--r-- 1 root root 2182152 Sep 2 16:22 sandbox_client_64_krs
    -rw-r--r-- 1 root root 2354680 Sep 2 16:22 sandbox_client_64_movie
    -rw-r--r-- 1 root root 2755720 Sep 2 16:22 sandbox_client_64_rpg
    -rw-r--r-- 1 root root 2195160 Sep 2 16:22 sandbox_client_64_ssp
    -rw-r--r-- 1 root root 3438592 Sep 2 16:22 sandbox_fps.exe
    -rw-r--r-- 1 root root 3001856 Sep 2 16:22 sandbox_krs.exe
    -rw-r--r-- 1 root root 206401 Sep 2 16:22 sandbox_master
    -rw-r--r-- 1 root root 1448603 Sep 2 16:22 sandbox_master.exe
    -rw-r--r-- 1 root root 3219456 Sep 2 16:22 sandbox_movie.exe
    -rw-r--r-- 1 root root 3571712 Sep 2 16:22 sandbox_rpg.exe
    -rw-r--r-- 1 root root 356484 Sep 2 16:22 sandbox_server_32_fps
    -rw-r--r-- 1 root root 300044 Sep 2 16:22 sandbox_server_32_movie
    -rw-r--r-- 1 root root 366888 Sep 2 16:22 sandbox_server_64_fps
    -rw-r--r-- 1 root root 308376 Sep 2 16:22 sandbox_server_64_movie
    -rw-r--r-- 1 root root 3094528 Sep 2 16:22 sandbox_ssp.exe
    -rw-r--r-- 1 root root 303616 Sep 2 16:22 SDL.dll
    -rw-r--r-- 1 root root 51200 Sep 2 16:22 SDL_image.dll
    -rw-r--r-- 1 root root 160256 Sep 2 16:22 SDL_mixer.dll
    -rw-r--r-- 1 root root 100352 Sep 2 16:22 zlib1.dll
Hope this helps.

ps: SB 2.8 ran just fine when "installed" locallay. ie: Decompressed downloaded file into mt home folder; created a launcher; ran just fine....

Re: Just installed 2.8

Posted: September 2nd, 2012, 6:03 am
by Hirato
that seems to be the crux of the problem, you lack permissions to enter the directories in there.
the directories all need the 'x' flag set to true, unfortunately I don't have any quick one-liners that won't set everything to executable as a consequence.

you can try 'chmod -R +X /usr/local/share/games/sandbox/' though.

But eh, if it's this big a problem, just keep it in your home and run it from there.

Re: Just installed 2.8

Posted: September 2nd, 2012, 7:10 pm
by johnno56
Thank you for your suggestions and patience. Much appreciated.