Problem with models ilumination after a wrong edit action

Having issues not related to a specific Sandbox game mode? Get help here!
Please also read the when posting support requests.

[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
Neofito
Member
Member
Posts: 26
Joined: January 5th, 2013, 5:54 pm
Name: Neofito
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Problem with models ilumination after a wrong edit action

Postby Neofito » February 20th, 2013, 7:26 pm

I'm pretty sure that I pressed a comand key/keys by accident while in edit-mode, I didn't notice anything and I saved my map; but now I've noticed that all models look grey/black without colour or ilumination.
Set fullbright to 1 solved it, but then I noticed that with this option all my blendmaps were messed; I've also removed the most recent .back files for my map, but the models are still black/colourless; and haven't been able to find any information about this.
So please, tell me what is the comand I have to use to give again light/color to my models.
Thanks in advance

Hirato
Developer
Developer
Posts: 689
Joined: May 30th, 2009, 1:23 pm
IRC Username: hirato
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Problem with models ilumination after a wrong edit actio

Postby Hirato » February 20th, 2013, 8:46 pm

recalculate the lightmaps? models take their light info from the local area.
also make sure they're not inside geometry, that's usually a common cause of unlit models.
This is not a url, clicking it is pointless

Neofito
Member
Member
Posts: 26
Joined: January 5th, 2013, 5:54 pm
Name: Neofito
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Problem with models ilumination after a wrong edit actio

Postby Neofito » February 21st, 2013, 7:32 pm


Neofito
Member
Member
Posts: 26
Joined: January 5th, 2013, 5:54 pm
Name: Neofito
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Problem with models ilumination after a wrong edit actio

Postby Neofito » February 24th, 2013, 6:51 am

Well, add the fullbright 1 option into the art.cfg of my map worked, and the models appear with right colours and lights, though the blendmaps stil don't work.

I've gone with a test map, and I've found what happened, seems that I pressed the L key when I was into blendpaintmode (value 2), hence it has been easy find what i did wrong, but I haven't been able to find how to solve it, any help would be apreciated; maybe a command to go back with the default settings??

Thanks in advance

Neofito
Member
Member
Posts: 26
Joined: January 5th, 2013, 5:54 pm
Name: Neofito
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Problem with models ilumination after a wrong edit actio

Postby Neofito » February 25th, 2013, 8:49 pm

Just found how to recover the "back" files, i wasn't doing it in the right way, but this post: viewtopic.php?f=8&t=4174 has opened my eyes :shock: ;)

Thanks chocolatepie33 for the answer, and Ghostman Gaming for the question ;)

Neofito
Member
Member
Posts: 26
Joined: January 5th, 2013, 5:54 pm
Name: Neofito
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Problem with models ilumination after a wrong edit actio

Postby Neofito » February 28th, 2013, 6:22 pm


Neofito
Member
Member
Posts: 26
Joined: January 5th, 2013, 5:54 pm
Name: Neofito
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Problem with models ilumination after a wrong edit actio

Postby Neofito » March 2nd, 2013, 3:35 pm


Neofito
Member
Member
Posts: 26
Joined: January 5th, 2013, 5:54 pm
Name: Neofito
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Problem with models ilumination after a wrong edit actio

Postby Neofito » March 13th, 2013, 7:28 pm

Nobody has any idea what could be the problem and its solution? :( :roll: :?: :(

User avatar
Leo_V117
Support Team
Support Team
Posts: 1640
Joined: February 16th, 2010, 8:00 pm
Name: Leo
IRC Username: Leo_V117
Location: That one place...
Contact:

Re: Problem with models ilumination after a wrong edit actio

Postby Leo_V117 » March 17th, 2013, 10:20 pm

Firstly, you've just violated a pretty basic rule several times... Unless they've been updated since I was last here. If they're still the same, you may realize that you've double-posted multiple times... There is an "Edit Post" option for a reason...

Secondly, Have you maybe tried looking for a [mapname].cfg within the save destination folder? If it exists, and you haven't created it/modified it... Delete it, likewise with the [mapname]-art.cfg... Or, open [mapname]-art.cfg and have a look for a line that involves "mdlfullbright"... If you find it, remove it and reload the map. This may repair the problem. If not, delete your "defaults.cfg" file located in the "mystuff/[modename]/data" folder...

Just a note, you may need to take your time and browse for the files I mentioned as I've just returned to Sandbox after about a year, and I don't remember a great deal.




Neofito
Member
Member
Posts: 26
Joined: January 5th, 2013, 5:54 pm
Name: Neofito
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Problem with models ilumination after a wrong edit actio

Postby Neofito » March 21st, 2013, 3:32 pm

Thanks for your answer Leo_V117
I've looked into the files you mention, and have gone with different setting of mdlfullbright and fullbright, but I wasn't able to fix the problem.
The next step was uninstall and reinstall and go with a totally new map, but I kept getting the same error; therefore I'm at the same point :?

And about double-post, I'v always understood how post different topics in different boards with the same question; what I've done is add new posts updating information but always into the same topic.
I haven't used the edit option, since it wasn't just add something forgotten in the post just made, I was adding new information about the topic after a few days; and I think that the only way to show out to the forums users that there is something new about the topic is create a new post, because edit an existing post wouldn't show that new information has been added.

But if it is against the forums rules, I only can say that I'm sorry, since in wasn't intended.


[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Return to “Sandbox General Support”

Who is online

Users browsing this forum: No registered users and 4 guests