Dragons, teleporters & such don't work like they used to

Chat and ask questions about the RPG Maker Mode here.
GeekyGuy8705
Member
Member
Posts: 6
Joined: January 15th, 2013, 11:42 pm
Name: Jeremiah

Dragons, teleporters & such don't work like they used to

Postby GeekyGuy8705 » January 18th, 2013, 1:35 pm

I could get a dragon to fly around a volcano, or a wolf to chase you through a forest, or have rats scurry through a sewer, or set up a long series of working teleporters in a deadly labyrinth with almost no effort at all. Not since the latest updates though. Now I can't seem to be able to get any of it to work like I used to. I downloaded 2.8 and can do even less with PAS. I tried to use my older version, but they still won't work. I downloaded the software again and again and still have the same issues. Know what the *heck* is going on? Do I need to put a clip around the maps or something?

Hirato
Developer
Developer
Posts: 689
Joined: May 30th, 2009, 1:23 pm
IRC Username: hirato

Re: Dragons, teleporters & such don't work like they used to

Postby Hirato » January 18th, 2013, 8:33 pm

The only thing that changed in the 2.8.0 release that is incompatible with 2.7.1 and earlier, is how the dialogue trees are set up.
2.7.0/2.7.1 are fully forward compatible

As for 2.6.x to 2.7.0...

Code: Select all

* removed script slots and replaced with a signal based approach to scripting
   for example r_script_collide is now r_script_signal collide; note it is case sensitive like everything else.
* named lookup script subsystem, has its own stack and tracks things independently of CubeScript.
* Modified folder hierarchy, uses a more classical and less confusing approach to identifying unique artefacts. This has the added bonus of making patches simple and painless. Unfortunately finding the one you want is now a chore
* commands to select and modify definitions and many aspects of entities and an accompanying menu.
* a few basic AI directives
* rewrote particle effects to not encompass 3 stages, each required stage now points to a separate effect.
* allowed the HUd to be redefined via script
* rewrote cutscene subsystem, interpolation gradients can now be defined with ease, and this includes improved support for on screen items, such as images.


All of these changes break compatibility with 2.6.x.


If you've upgraded from 2.7.0, I can only conclude you're doing something wrong,
If you've come from 2.6.0, pretty much everything in your game will error out, but if you need advice and tips to converting, I'm open to questions.
This is not a url, clicking it is pointless


Return to “RPG Maker Mode”

Who is online

Users browsing this forum: No registered users and 1 guest